about summary refs log tree commit diff
path: root/machines/hp-compaq/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/hp-compaq/configuration.nix')
-rwxr-xr-xmachines/hp-compaq/configuration.nix16
1 files changed, 5 insertions, 11 deletions
diff --git a/machines/hp-compaq/configuration.nix b/machines/hp-compaq/configuration.nix
index 958088c..cc61647 100755
--- a/machines/hp-compaq/configuration.nix
+++ b/machines/hp-compaq/configuration.nix
@@ -1,22 +1,16 @@
 { config, pkgs, ... }:
 
 {
-  imports =
-    [ # Include the results of the hardware scan.
-      ./hardware-configuration.nix
-    ];
 
-  boot.loader.grub.enable = true;
-  boot.loader.grub.version = 2;
-  boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
+  imports = [
+	../base.nix
+	../pl.nix
+	../../modules/larbs.nix
+  ];
 
   networking.hostName = "hp-compaq";
 
-  networking.useDHCP = false;
-  networking.interfaces.enp2s0.useDHCP = true;
-
   environment.systemPackages = with pkgs; [
   ];
-
 }