about summary refs log tree commit diff
path: root/machines/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/base.nix')
-rwxr-xr-xmachines/base.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/machines/base.nix b/machines/base.nix
index b706452..5c545ae 100755
--- a/machines/base.nix
+++ b/machines/base.nix
@@ -16,6 +16,7 @@
     wget vim curl htop file
     stdenv git zip unzip
     dnsutils ripgrep jq
+    any-nix-shell
   ];
 
   console.font = "${pkgs.terminus_font}/share/consolefonts/ter-v22n";
@@ -70,6 +71,7 @@
     syntaxHighlighting.enable = true;
 
     promptInit = ''
+      any-nix-shell zsh --info-right | source /dev/stdin
       autoload -U colors && colors
       PS1="%B%{$fg[red]%}[%{$fg[yellow]%}%n%{$fg[green]%}@%{$fg[blue]%}%M %{$fg[magenta]%}%~%{$fg[red]%}]%{$reset_color%}$%b "
     '';