about summary refs log tree commit diff
path: root/machines/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/base.nix')
-rwxr-xr-xmachines/base.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/machines/base.nix b/machines/base.nix
index 5c545ae..75935ec 100755
--- a/machines/base.nix
+++ b/machines/base.nix
@@ -36,9 +36,17 @@
   };
 
   ## === XDG ===
-  environment.variables = {
+  environment.variables = rec {
     XDG_CONFIG_HOME = "$HOME/.config";
+    XDG_CACHE_HOME = "$HOME/.cache";
     XDG_DATA_HOME = "$HOME/.local/share";
+    XDG_RUNTIME_DIR = "/run/user/$UID";
+
+    # == XDG overrides ==
+    ICEAUTHORITY = "${XDG_CACHE_HOME}/ICEauthority";
+    XAUTHORITY = "$XDG_RUNTIME_DIR/Xauthority";
+    LESSHISTFILE = "${XDG_CACHE_HOME}/lesshist";
+    MPLAYER_HOME = "$XDG_CONFIG_HOME/mplayer";
   };
 
   ## === Vim configuration ===