about summary refs log tree commit diff
path: root/machines/asus/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/asus/hardware-configuration.nix')
-rw-r--r--machines/asus/hardware-configuration.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/machines/asus/hardware-configuration.nix b/machines/asus/hardware-configuration.nix
new file mode 100644
index 0000000..ef6aaa7
--- /dev/null
+++ b/machines/asus/hardware-configuration.nix
@@ -0,0 +1,39 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+  imports =
+    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+    ];
+
+  boot.initrd.availableKernelModules = [ "xhci_pci" "usb_storage" "usbhid" "sd_mod" "sdhci_acpi" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  boot.initrd.prepend = [ "${./acpi_override}" ];
+
+  boot.loader.grub = {
+    efiSupport = true;
+    device = "nodev";
+  };
+
+  fileSystems."/" = lib.mkForce
+    { device = "/dev/disk/by-uuid/7ee757e6-4f50-4681-9b5b-27c2cb1f84e4";
+      fsType = "ext4";
+    };
+
+  fileSystems."/boot" = lib.mkForce
+    { device = "/dev/disk/by-uuid/5386-B9AE";
+      fsType = "vfat";
+    };
+
+  swapDevices = lib.mkForce
+    [ { device = "/dev/disk/by-uuid/8924970e-10bd-4d6f-a137-61d05a886106"; }
+    ];
+
+  nix.maxJobs = lib.mkDefault 4;
+  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}