about summary refs log tree commit diff
path: root/machines/asus/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/asus/configuration.nix')
-rwxr-xr-xmachines/asus/configuration.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/machines/asus/configuration.nix b/machines/asus/configuration.nix
new file mode 100755
index 0000000..444f9f0
--- /dev/null
+++ b/machines/asus/configuration.nix
@@ -0,0 +1,42 @@
+{ config, pkgs, ... }:
+
+{
+
+  imports = [
+    ../base.nix
+    ../pl.nix
+    ../../modules/larbs.nix
+    ../../modules/trackpad.nix
+  ];
+
+  networking = {
+    hostName = "asus-t100";
+
+    networkmanager = {
+      enable = true;
+      wifi.backend = "iwd";
+    };
+  };
+
+
+  environment.systemPackages = with pkgs; [
+    libimobiledevice
+  ];
+
+  services.usbmuxd.enable = true;
+
+  services.acpid.enable = true;
+
+  # Battery
+  services.tlp.enable = true;
+
+  services.xserver = {
+    videoDrivers = [ "intel" ];
+    deviceSection = ''
+      Option      "Backlight"  "intel_backlight"
+      Option "DIR" "2"
+      Option "TearFree" "true"
+    '';
+  };
+
+}