about summary refs log tree commit diff
path: root/machines/adax/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/adax/hardware-configuration.nix')
-rwxr-xr-xmachines/adax/hardware-configuration.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/machines/adax/hardware-configuration.nix b/machines/adax/hardware-configuration.nix
new file mode 100755
index 0000000..99b9002
--- /dev/null
+++ b/machines/adax/hardware-configuration.nix
@@ -0,0 +1,38 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+  imports =
+    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+    ];
+
+  boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ata_piix" "usbhid" "usb_storage" "floppy" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  boot.loader.grub.enable = true;
+  boot.loader.grub.version = 2;
+  boot.loader.grub.device = "/dev/sdc"; # or "nodev" for efi only
+
+  networking.useDHCP = false;
+  networking.interfaces.enp3s0.useDHCP = true;
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/6b9e05c9-827e-4a34-bb35-f2a3da149f44";
+      fsType = "ext4";
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/7F96-4F40";
+      fsType = "vfat";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/cda58eb8-fc1e-4bea-9dca-b119a1da2267"; }
+    ];
+
+  nix.maxJobs = lib.mkDefault 2;
+}