about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix39
1 files changed, 22 insertions, 17 deletions
diff --git a/flake.nix b/flake.nix
index a966d4d..6f92c24 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,23 +1,28 @@
 {
-  description = "Nixos config flake";
+	description = "Nixos config flake";
 
-  inputs = {
-    nixpkgs.url = "github:nixos/nixpkgs/nixos-24.05";
+	inputs = {
+		nixpkgs.url = "github:nixos/nixpkgs/nixos-24.05";
 
-    home-manager = {
-      url = "github:nix-community/home-manager";
-      inputs.nixpkgs.follows = "nixpkgs";
-    };
-  };
+		home-manager = {
+			url = "github:nix-community/home-manager";
+			inputs.nixpkgs.follows = "nixpkgs";
+		};
+	};
 
-  outputs = { self, nixpkgs, ... }@inputs: {
-    nixosConfigurations.nixos = nixpkgs.lib.nixosSystem {
-      specialArgs = {inherit inputs;};
-      modules = [
-        ./machines/x220-gnome/configuration.nix
-        inputs.home-manager.nixosModules.default
+	outputs = { self, nixpkgs, ... }@inputs: {
+		nixosConfigurations.nixos = nixpkgs.lib.nixosSystem {
+			specialArgs = {inherit inputs;};
+			modules = [
+				./machines/x220-gnome/configuration.nix
+					inputs.home-manager.nixosModules.default
+					{
+						home-manager.useGlobalPkgs = true;
+						home-manager.useUserPackages = true;
+						home-manager.users.pn = import ./home.nix;
+					}
 
-      ];
-    };
-  };
+			];
+		};
+	};
 }