about summary refs log tree commit diff
path: root/platforms/linux/configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-03 08:57:55 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-03 08:57:55 +0100
commitae684af32dcb40a51153132fd5127d98d45d4b83 (patch)
tree495087128515048e3959c8177d5b480636141778 /platforms/linux/configuration.nix
parentb3bd9ff5c9ad4cb7c785f5a56ce4d3f3208e23d7 (diff)
downloaddots-ae684af32dcb40a51153132fd5127d98d45d4b83.tar.gz
dots-ae684af32dcb40a51153132fd5127d98d45d4b83.zip
Update
Diffstat (limited to 'platforms/linux/configuration.nix')
-rw-r--r--platforms/linux/configuration.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/platforms/linux/configuration.nix b/platforms/linux/configuration.nix
index c353c59..3ef93dd 100644
--- a/platforms/linux/configuration.nix
+++ b/platforms/linux/configuration.nix
@@ -39,6 +39,7 @@ in
     [ # Include the results of the hardware scan.
       # <home-manager>/nixos
       ../../modules/dockd.nix
+      ../../modules/trackpad.nix
       ../../hardware-configuration.nix
     ];
 
@@ -55,6 +56,7 @@ in
 
   boot.extraModulePackages = with pkgs.linuxPackages; [
     v4l2loopback
+    acpi_call
   ];
 
   boot.kernelModules = [ "v4l2loopback" ];
@@ -143,7 +145,7 @@ in
     # Basic tools
     stdenv wget vim curl htop dnsutils zip unzip
     zsh neovim ripgrep jq groff file pinentry_gnome
-    ssh-ident busybox_utils usbutils
+    ssh-ident busybox_utils
 
     # XORG perfs
     xorg.xorgserver xorg.xf86inputevdev xorg.xf86inputsynaptics xorg.xf86inputlibinput
@@ -168,7 +170,7 @@ in
     quickserve ueberzug chafa
 
     # Thinkpad utils
-    nur.repos.pn.dockd
+    nur.repos.pn.dockd acpi tpacpi-bat
 
     wineStaging
 
@@ -224,6 +226,9 @@ in
   # services.udev.packages = [
   #   pkgs.android-udev-rules
   # ];
+  services.udev.packages = [ pkgs.libu2f-host ];
+
+  services.pcscd.enable = true;
 
   # Enable the OpenSSH daemon.
   # services.openssh.enable = true;
@@ -245,6 +250,9 @@ in
 
   services.acpid.enable = true;
 
+  # Battery
+  services.tlp.enable = true;
+
   # Enable sound.
   sound.enable = true;
   hardware.pulseaudio.enable = true;
@@ -257,7 +265,10 @@ in
   # services.xserver.xkbOptions = "eurosign:e";
 
   # Enable touchpad support.
-  services.xserver.libinput.enable = true;
+  services.xserver.libinput = {
+    enable = true;
+    accelSpeed = "0.8";
+  };
 
   # Enable the KDE Desktop Environment.
   #services.xserver.displayManager.sddm.enable = true;