about summary refs log tree commit diff
path: root/home.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-09-25 21:56:39 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-09-25 21:56:39 +0200
commita8e13f03d058a57428075d76b682e279e64ca2f6 (patch)
tree5057fcf11b357c75861c934e71f1f56b4b0b265f /home.nix
downloaddots-a8e13f03d058a57428075d76b682e279e64ca2f6.tar.gz
dots-a8e13f03d058a57428075d76b682e279e64ca2f6.zip
Init
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/home.nix b/home.nix
new file mode 100644
index 0000000..d550141
--- /dev/null
+++ b/home.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, ... }:
+
+{
+  # Let Home Manager install and manage itself.
+  programs.home-manager.enable = true;
+
+  # Home Manager needs a bit of information about you and the
+  # paths it should manage.
+  home.username = "pn";
+  home.homeDirectory = "/Users/pn";
+
+  imports = [
+    ./programs/git.nix
+  ];
+
+  home.packages = with pkgs; [
+    gnupg
+    nur.repos.pn.larbs-mail
+  ];
+
+  # This value determines the Home Manager release that your
+  # configuration is compatible with. This helps avoid breakage
+  # when a new Home Manager release introduces backwards
+  # incompatible changes.
+  #
+  # You can update Home Manager without changing this value. See
+  # the Home Manager release notes for a list of state version
+  # changes in each release.
+  home.stateVersion = "20.09";
+}