about summary refs log tree commit diff
path: root/home.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-10-03 22:06:43 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-10-03 22:06:43 +0200
commit342155ced8fc78b608f23454cb631decb0b7be9b (patch)
tree2cc4ffc422d645e17cf456cdcc780287df311b3f /home.nix
parent5d3c8e21d2d79a6ed3e324b833002a9bb0317b34 (diff)
downloaddots-342155ced8fc78b608f23454cb631decb0b7be9b.tar.gz
dots-342155ced8fc78b608f23454cb631decb0b7be9b.zip
Update config
Diffstat (limited to 'home.nix')
-rw-r--r--home.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/home.nix b/home.nix
index 69ce6d5..3259387 100644
--- a/home.nix
+++ b/home.nix
@@ -4,7 +4,12 @@ let
   common_packages = import ./platforms/common-packages.nix pkgs;
   isDarwin = builtins.currentSystem == "x86_64-darwin";
   platformSetup =
-    if isDarwin then ./platforms/darwin else ./platforms/linux;
+    if isDarwin then [
+      ./platforms/darwin
+    ] else [
+      ./platforms/linux
+      ./programs/rclone.nix
+    ];
 in
 {
   # Errors on linux
@@ -22,11 +27,10 @@ in
 
   imports = [
     # Platform specific config
-    platformSetup
     ./programs/zsh
     ./programs/newsboat
     ./programs/git.nix
-  ];
+  ] ++ platformSetup;
 
   home.packages = with pkgs; [
     # Basic
@@ -34,6 +38,9 @@ in
     pnvim
     nur.repos.pn.larbs-mail
     nur.repos.pn.larbs-news
+    amfora
+    translate-shell
+    nix-index
 
     # Misc
     browserpass