about summary refs log tree commit diff
path: root/hardware-configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-10-03 22:06:43 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-10-03 22:06:43 +0200
commit342155ced8fc78b608f23454cb631decb0b7be9b (patch)
tree2cc4ffc422d645e17cf456cdcc780287df311b3f /hardware-configuration.nix
parent5d3c8e21d2d79a6ed3e324b833002a9bb0317b34 (diff)
downloaddots-342155ced8fc78b608f23454cb631decb0b7be9b.tar.gz
dots-342155ced8fc78b608f23454cb631decb0b7be9b.zip
Update config
Diffstat (limited to 'hardware-configuration.nix')
-rw-r--r--hardware-configuration.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/hardware-configuration.nix b/hardware-configuration.nix
new file mode 100644
index 0000000..84eb8cd
--- /dev/null
+++ b/hardware-configuration.nix
@@ -0,0 +1,33 @@
+# ThinkPad X220
+
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+  imports =
+    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+    ];
+
+  boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/e00c989b-b3fd-469e-b894-ea609fb4d7fa";
+      fsType = "ext4";
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/2f0948cd-a0de-41c0-a341-e9fe01460fd3";
+      fsType = "ext3";
+    };
+
+    swapDevices = [ {
+      device = "/dev/sda2"; } ];
+
+  nix.maxJobs = lib.mkDefault 4;
+  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}